×
Spam Prevention - Please Read! (23 Apr 2021)

Due to a problem with spammers the rules for posting in the forums have changed for new users.

Newly registered users won't have their posts published until a moderator approves them.

The classic movie crash...

More
6 months 1 week ago #2060 by jac
The classic movie crash... was created by jac
Hello guys, i recently remembered that awsome game that is Swat 3
got it on GoG and found out it dosent work...
i have the traditional DDERR_GENERIC error

I tried the replacement videos but it crashes the same way.
I tried the compatibility modes, dosent work...

I tried the -nointro command and the game start, but as i really want to play the career mode this is useless for me.
I heard something about uninstalling the "LAV filters" but even if i have the LAV codecs i have no ideas how to remove the LAV filters
Anyway, i tried to go in the LAV video format options and unchecked all the intel indeo boxes, but it still do the same bug.

also i have ran the line : regsvr32 %SystemRoot%\SysWOW64\ir50_32.dll  successfully but still witout any changes...

Any ideas ?

 

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #2062 by Slippery Jim
Replied by Slippery Jim on topic The classic movie crash...
Can your machine handle 640x480 and 800x600 resolutions? Some modern computers don't like these old resolutions (I suspect this is a problem on a lot of laptops)

From my understanding you would only have the lav filters if you installed the "CCCP: Combined Community Codec Pack" but I could be wrong.   Any chance you installed those?

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #2064 by jac
Replied by jac on topic The classic movie crash...
no i did not installed theses codecs... should i ?

As for the resolution, the problem is not here, if i use the -nointro command, the game run just fine.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #2065 by Slippery Jim
Replied by Slippery Jim on topic The classic movie crash...

no i did not installed theses codecs... should i ?

As for the resolution, the problem is not here, if i use the -nointro command, the game run just fine.




 

The codec pack isn't recommended even though people in the forums report success with it.   The problem is the codec pack installs a lot of old codecs that may create other types of issues potentially.   You can compare it to using a sledgehammer to kill a fly.

The -nointro flag skips the intro movies only of course but the game still would crash in certain missions that play movies.  The movies are 640x480 so perhaps your machine is having trouble switching to that resolution.

Update:  I am curious if you load the game with the -nointro flag can you play the education movies in the game?   If so then the codec isn't the problem but the resolution.   Start a regular mission.  Click EDUCATION button and then choose STRUCTURE and USE OF FORCE.  There should be a video icon to click to play the movie.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #2066 by DarkSynopsis
Replied by DarkSynopsis on topic The classic movie crash...
If its a resolution switching issue could always try -window? would have to be running a menu that is below the res of the desktop though otherwise it complains its out of bounds.

Also dgVoodoo could prevent the res changing the same way it can for loading screens, I think anyway... not tested since I always run -nointro and don't touch anything SP.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #2067 by Slippery Jim
Replied by Slippery Jim on topic The classic movie crash...
Yup dgVoodoo with Swat 3 can give an error but usually it is a different error saying that it can't do the 2D resolution.

The -window startup flag is a good suggestion for another test to help try to narrow the problem down.

Friendly reminder to anyone troubleshooting Swat 3:  While troubleshooting things like this I highly recommend NOT using the Last Resort mod and even NOT use dgVoodoo. Limit the possible sources of trouble and get Swat 3 running alone by itself.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #2069 by jac
Replied by jac on topic The classic movie crash...
All cinematics in the game crash my game, the education, the cutscenes after a mission loss are the same, they are all crashing my game.

the -window flag dosent allow my game to run, it give the following error message :
"Sorry this program requires 16 bit color mode"

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #2070 by DarkSynopsis
Replied by DarkSynopsis on topic The classic movie crash...

the -window flag dosent allow my game to run, it give the following error message :
"Sorry this program requires 16 bit color mode

You need to properties the swat.exe and in compatibility enable reduced color mode and set to 16-bit.

Please Log in or Create an account to join the conversation.

Time to create page: 0.152 seconds
Powered by Kunena Forum